charm AT lists.siebelschool.illinois.edu
Subject: Charm++ parallel programming system
List archive
- From: Phil Miller <mille121 AT illinois.edu>
- To: Charm Mailing List <charm AT cs.illinois.edu>
- Subject: [charm] Beta 3 (Release Candidate) of Charm++ 6.3.0 available
- Date: Wed, 2 Mar 2011 15:08:48 -0600
- List-archive: <http://lists.cs.uiuc.edu/pipermail/charm>
- List-id: CHARM parallel programming system <charm.cs.uiuc.edu>
The third beta of Charm++ 6.3.0 is now available for testing. We've
fixed a number of bugs since beta 2. This is a release candidate - we
believe there are no outstanding issues that will impede production
usage. Please test your applications and report any problems you
encounter.
git clone git://charm.cs.illinois.edu/charm.git
git checkout v6.3.0-beta3
Aaron Becker (2):
Added documentation for typed reductions
Fix reductiontarget code generation for groups and nodegroups
Abhinav Bhatele (9):
cray pmi: make the error more explicit
cputimer: guard cputime variables with CMK_LB_CPUTIMER
cputimer: this changes the way background time is calculated
cputimer: change background load to be walltime
cputimer: CMK_LB_CPUTIMER ifdefs in NeigborLB code
cputimer: use walltime when cputimer not available
cputimer: WSLB will not be compiled by default
cputimer: turn off cpu timer calls by default
ck-ldb: turn off recording of min and max wall time for chares
Abhinav S Bhatele (23):
jacobi3d-sdag: remove incomplete load balancing support
RecBipartLB: ldb strategy using recursive bipartition
kNeighbor: simplify the code
kNeighbor: change the load pattern
kNeighbor: remove more unused functions
kNeighbor: finally behaving as expected of a load balancing benchmark
ck-ldb: LDBs which use METIS are using sendToList
WSLB: the target already exists as part of EveryLB
Merge branch 'charm' of charmgit:charm into charm
doc: fix compilation errors
lb_test: remove unnecessary lib paths
ck-ldb: this should fix MetisLB and ScotchLB crashes
Merge branch 'charm' of charmgit:charm into charm
ck-ldb: add documentation
doc: update doc for adding a new load balancer
ck-ldb: make the ldb debug prints more readable and consistent
stencil3d: fix the calculation of time per step
lb_test: add sizing information through sizer
doc: new image for ckgraph api
doc: expand on the available load balancing options
Merge branch 'charm' of charmgit:charm into bhatele/ldbcputimer
NumaLB should not be there
ck-graph: fix a problem with translating decisions
Chao Mei (6):
Fixed message tracing on comm thread (to trace those entry
methods that need
Added a macro to turn off user event when tracing
MPI_Isend/MPI_Recv in order to reduce the overhead of comm thread
tracing.
Merge branch 'charm' of charmgit:charm into charm
Fixed a bug in setting the starting time of tracing MPI_Isend
fixed a bug in creating charm SMP-aware multicast tree where the
order of local indices is not maintained correctly.
Merge branch 'charm' of charmgit:charm into charm
Eric Bohm (3):
add -module CommonLBs to the projections target lines.
auto tune the SetLBPeriod based on how long is actually takes to run
add text noting the relevance of LBPeriod to AtSync
Gengbin Zheng (74):
a slight better way to implement CpvInitialized() under TLS-based
Cpvs, to reduce some race condtion in SMP.
Revert "fixed the cmipool init."
minor formatting change to the previous commit.
added a ";" before the CkpvDeclare(char**,Ck_argv);
turn off TLS based Cpv when not using gnu compiler.
registerCPReductions needs to be initnode call, and called once
per node (for SMP). reduceTable is node level data structure.
not all C compilers(e.g. xlc, vc++) support inline in C code.
added a const to the group ID in setGroupDepID
set dependence of location mgr to ckmap group.
register qd callback in a separate CcdUSER condition event, so
that it can be called separately.
raise CcdUSER event to activate QD.
Merge branch 'charm' of charmgit:charm into charm
smp switch to os malloc.
fix work stealing hanging problem on Jagua
moved CmiInitCPUAffinityUtil to be after CmiTmpInit since it may need it.
Merge branch 'charm' of charmgit:charm into charm
generic64 did not work with SMP due to using a global pointer
mapping table.
Merge branch 'charm' of charmgit:charm into charm
changedto use generic64 Cth for SMP. it should work on lapi/aix
when __thread is supported.
Merge branch 'charm' of charmgit:charm into charm
nicer looking changes for previous commit
Merge branch 'charm' of charmgit:charm into charm
change back to GNU malloc since os malloc did crash megatest.
a fix for bluedrop multicore startup crash, where it seems that
mmap unmap'ed some lower region (2GB) of memory that makes it
available for malloc, which then is trashed by something else.
fixed a bug in workstealing that when stealing is in progress,
beginIdle should not steal again.
Merge branch 'charm' of charmgit:charm into charm
subtle: added memory read and write fence to CpvInitialize to
make sure that after non-zero ranks exit from the while loop, it gets
the cpv variables ready to use.
use smp lock to protect the syscall and fopen in
CmiInitCPUAffinityUtil() function.
Merge branch 'charm' of charmgit:charm into charm
fixed compilation error for non-Linux platforms.
some minor optimization: reuse messages, remove calls to QD events.
Merge branch 'charm' of charmgit:charm into charm
fixed the broken Make.depends
updated
when skip topology, only rank 0 initialize the topo data structure
fixed some minor bugs in LBTopo_torus_nd_smp class to make it
actually works
Merge branch 'charm' of charmgit:charm into charm
a CcdTOPOLOGY_AVAIL ccd condition, which is raised when topology
info is available on each processor.
remove the limitation of CMK_MAX_PTHREADS for TLS implementation
of Cpv variables.
Merge branch 'charm' of charmgit:charm into charm
CMK_TAG(Cpv_addr_,v) need to include one extra for comm. thread.
added two command line options:
added two conv-mach macros CMK_MMAP_PROBE and CMK_MMAP_TEST to
control the default setting.
fixed some compilation error on windows.
Merge branch 'charm' of charmgit:charm into charm
isomalloc region tmp file can not be under /tmp, because it needs
to be on a shared fiel system for every pe to read.
fixed the case of using cputimer when not using reduction tree.
remove the line: #define CMK_64BIT 0
test if _setjmp/_longjmp exist
use _setjmp when it is supported.
fixed compiler warnings for icc
Revert "Make workstealing more proactive. Still before being idle"
change the formular in finding the next victim (get rid of notaskpe)
Revert "register qd callback in a separate CcdUSER condition
event, so that it can be called separately."
added build time option --enable/disable-stats to enable/disable
stats collection.
use CMK_WITH_STATS to enable stats collection.
not working when running build on existing build
minor change so the build make changes from scratch (some files
are hence removed)
changed CMK_OPTIMIZE to CMK_ERROR_CHECKING
link conv-mach-opt.sh to include
Merge branch 'charm' of charmgit:charm into charm
--with-lbtime-type=[float|double} to specify the type of the load
balancing timing
propagate LBRealType for load balancing timer type
get rid of return statements so that it gets to
CcdRaiseCondition(CcdTOPOLOGY_AVAIL) properly.
when STATS is off, only PE 0 complains if user tries to use +cs.
fixed a typo in getting processor count.
removed a debug print.
use CldCountTokens instead of CldLoad() to estimate the current
load. CldLoad() has all the msg in charm csd queue, which might now be
all tokens.
Merge branch 'charm' of charmgit:charm into charm
changed lbtime default type back to double (from float)
change so that when +pemap and +commap present, cpuaffinity is
automatically on.
added description of --with-lbtime-type=type option
minor change to make charm output uniform.
Merge branch 'charm' of charmgit:charm into charm
Osman Sarood (3):
TempAwareLB added
Maj min example
Make file change for Maj min
Phil Miller (28):
RecBipartLB: Reduce exposure and fix a build break along the way
RecBipartLB: Minimize inclusions and prefer C++ headers
Remove an extraneous include
Remove another extraneous include
Remove old CVS header
MS VC++: Disable spurious macro definitions of min/max
Remove old CVS header
lapi-smp: Link the right pthread library for Linux or AIX
lapi-mpcc64: Compiler name and option selection for Linux and AIX support
Remove long-dead code
AMPI: Remove code that's been dead since 2000
DDT: Update old-style code and remove a VC++-ism
MS VC++: Define NOMINMAX at the compiler level, to avoid
inclusion order issues
Makefile: Delete warning-generating spurious whitespace
Infrastructure for external package interaction
build: Make it easier to incorporate new Makefiles in the build process
Make.lb: List LBs that need external libs for make depends, etc
configure: Add support for external METIS library
Merge branch 'metis' into charm
Distributed Completion Detection: Apps don't need to use QD
Move TempAwareGreedyLB out of the common set
Makefile_lb.sh: Remove noise obviated by version control
Select the size of the envelop refnum field at configure time
Expose the variable-size envelop refnum field in the API
Reduction userFlag: Cast default value of -1 to assigned type, to
silence warnings
Completion Detection: Compile with baseline runtime
Reference number field: missing middle interface
Remove CVS header
Ramprasad Venkataraman (1):
Documentation for CsdNextMessage() and the multiple unprocessed
msg queues in converse/charm++
Sameer Kumar (3):
Blue Gene/Q changes for charm++.
Add the -lmpl library.
Pointing to the latest xlc compiler.
Yanhua Sun (1):
Fixed inline bug on blue print
Yanhua Yanhua (9):
Minor change to nqueen example makefile
add search engine code in example/
add search engine code in examples/
Only use workstealing when processor number is more than 1
fix a bug in workstealing for processor=2
Commenting one line of initialization makes program incorrect.
Now this line is back
Merge branch 'charm' of charmgit:charm into charm
Make workstealing more proactive. Still before being idle
add workstealing proactive option to make stealing more proactive
Yanhua YanhuaSunLaptop (3):
fix a bug in seed load balancer about begin idle
comment out some unnecessary code about CldProcData in work stealing
Merge branch 'charm' of charmgit:charm into charm
-----------------------------------------------------------------------
hooks/post-receive
--
Charm++ Adaptive Runtime System and Libraries
- [charm] Beta 3 (Release Candidate) of Charm++ 6.3.0 available, Phil Miller, 03/02/2011
Archive powered by MHonArc 2.6.16.